小小千想和您聊一聊

当前位置: 首页> 技术分享> SpringBoot环境要求

SpringBoot环境要求

.基本说明

本系列教程采用Spring Boot 2.x.x.RELEASE版本;
需要Java 8+版本;
Spring Framework
5.0.4.RELEASE或更高版本;
Maven 3.2+或Gradle 4+。

另外Spring Boot本身内嵌了一些servlet容器:



.环境配置

1.安装配置JD8.0+

#检查java环境

$ java -version

2.安装配置Maven3.2+

#检查maven环境

$ mvn -v

3.选装配置Gradle4.0+

我们做web开发的时候,一般都是采用Maven环境,但是也可以使用Gradle来进行依赖包的下载管理,如果你的环境是Gradle,那么也可以尝试一下,本教程采用Maven环境!

Spring Boot提供了一个有用的Gradle插件,可以用来简化依赖声明和创建可执行的jar。

一个参考的Gradle依赖插件设置:


plugins {

    id 'org.springframework.boot' version '2.0.0.RELEASE'

    id 'java'

}

 

jar {

    baseName = 'firstProject'

    version =  '0.0.1-SNAPSHOT'

}

 

repositories {

    jcenter()

}

 

dependencies {

    compile("org.springframework.boot:spring-boot-starter-web")

    testCompile("org.springframework.boot:spring-boot-starter-test")

}


. SpringBoot项目创建方式

在ideal中创建SpringBoot项目的方式可以有3种:

· 1.通过idea的Spring Initializr来创建;

· 2.手动创建一个Maven工程,然后引入SpringBoot所需的dependency来完成;

· 3.通过Spring官网提供的模板来创建Spring boot项目,模板地址:https://start.spring.io/.


上一篇:SpringBoot概述

下一篇:Spring Initializr创建方式以及项目结构解析

QQ技术交流群

千锋Java锋迷群
870028642

加入群聊

用户登录

手机号:

密码:

图形验证码:

点击切换

用户注册

手机号:

登录密码:

图形验证码:

点击切换

短信验证码:

获取验证码

忘记密码

1安全验证

2重置密码

手机号:

图形验证码:

短信验证码:

获取验证码

忘记密码

1安全验证

2重置密码

新密码:

确认新密码:

获取课程

添加小千老师微信,获取课程信息

如何获取课程?

一、需拥有此本教材

如没有,可点击下方入口购买当当购买入口京东购买入口

二、添加小千老师,发送拥有凭证,解锁课程资源

1.购买该教材的订单信息
2.拥有的实体书信息等

更换手机号

新手机号:

图形验证码:

短信验证码:

获取验证码